summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorCory Benfield <lukasaoz@gmail.com>2017-05-24 10:20:07 -0700
committerCory Benfield <lukasaoz@gmail.com>2017-05-24 10:20:07 -0700
commitf3d310b299af587d668493f09d82c84c197d00fd (patch)
tree897bfca62465dad7e768f206cbb07a1e590a5515 /setup.py
parent874bca97cbfabd59cc8efd5381fdd08efc7c7f06 (diff)
downloadpython-requests-f3d310b299af587d668493f09d82c84c197d00fd.tar.gz
Turns out @kennethreitz suprise-broke the CI
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 6ad0bc35..b9588ebd 100755
--- a/setup.py
+++ b/setup.py
@@ -51,7 +51,7 @@ packages = [
requires = []
test_requirements = ['pytest>=2.8.0', 'pytest-httpbin==0.0.7', 'pytest-cov', 'pytest-mock']
-with open('requests/__init__.py', 'r') as fd:
+with open('requests/__init__.py', 'r', 'utf-8') as fd:
version = re.search(r'^__version__\s*=\s*[\'"]([^\'"]*)[\'"]',
fd.read(), re.MULTILINE).group(1)