diff options
author | phillip.eby <phillip.eby@6015fed2-1504-0410-9fe1-9d1591cc4771> | 2005-11-19 20:38:40 +0000 |
---|---|---|
committer | phillip.eby <phillip.eby@6015fed2-1504-0410-9fe1-9d1591cc4771> | 2005-11-19 20:38:40 +0000 |
commit | 15a14f4472d460be7db5034ba423af3e725329e5 (patch) | |
tree | 72fb86d76ad349a9a7bff41e2a5caddbccf9df33 /setup.py | |
parent | 6a231f55c6d62c308f2e32eeb98928fdfbff3a27 (diff) | |
download | python-setuptools-15a14f4472d460be7db5034ba423af3e725329e5.tar.gz |
Added ``tests_require`` keyword to ``setup()``, so that e.g. packages
requiring ``nose`` to run unit tests can make this dependency optional
unless the ``test`` command is run.
git-svn-id: http://svn.python.org/projects/sandbox/trunk/setuptools@41483 6015fed2-1504-0410-9fe1-9d1591cc4771
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 28 |
1 files changed, 14 insertions, 14 deletions
@@ -40,6 +40,7 @@ setup( py_modules = ['pkg_resources', 'easy_install', 'site'], zip_safe = False, # We want 'python -m easy_install' to work, for now :( + entry_points = { "distutils.commands" : [ "%(cmd)s = setuptools.command.%(cmd)s:%(cmd)s" % locals() @@ -49,7 +50,8 @@ setup( "eager_resources = setuptools.dist:assert_string_list", "namespace_packages = setuptools.dist:check_nsp", "extras_require = setuptools.dist:check_extras", - "install_requires = setuptools.dist:check_install_requires", + "install_requires = setuptools.dist:check_requirements", + "tests_require = setuptools.dist:check_requirements", "entry_points = setuptools.dist:check_entry_points", "test_suite = setuptools.dist:check_test_suite", "zip_safe = setuptools.dist:assert_bool", @@ -67,6 +69,17 @@ setup( "console_scripts": ["easy_install = setuptools.command.easy_install:main"], }, + + + + + + + + + + + classifiers = [f.strip() for f in """ Development Status :: 3 - Alpha Intended Audience :: Developers @@ -108,16 +121,3 @@ setup( - - - - - - - - - - - - - |