diff options
author | phillip.eby <phillip.eby@6015fed2-1504-0410-9fe1-9d1591cc4771> | 2006-09-22 00:03:56 +0000 |
---|---|---|
committer | phillip.eby <phillip.eby@6015fed2-1504-0410-9fe1-9d1591cc4771> | 2006-09-22 00:03:56 +0000 |
commit | 1c6f79f14ab8548790c785e31ac6afc965eb28a8 (patch) | |
tree | 8911332d3791a6d4f04bca37f1860fe02ab90fd2 /setup.py | |
parent | cf56b0d29e590751ce2d190c47b79ccf84c20f16 (diff) | |
download | python-setuptools-1c6f79f14ab8548790c785e31ac6afc965eb28a8.tar.gz |
Add support for "eggsecutable" headers: a /bin/sh script that is prepended
to an .egg file to allow it to be run as a script on Unix-ish platforms.
(This is mainly so that setuptools itself can have a single-file installer
on Unix, without doing multiple downloads, dealing with firewalls, etc.)
git-svn-id: http://svn.python.org/projects/sandbox/trunk/setuptools@51968 6015fed2-1504-0410-9fe1-9d1591cc4771
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 12 |
1 files changed, 6 insertions, 6 deletions
@@ -75,9 +75,13 @@ setup( "easy_install = setuptools.command.easy_install:main", "easy_install-%s = setuptools.command.easy_install:main" % sys.version[:3] - ], + ], "setuptools.file_finders": - ["svn_cvs = setuptools.command.sdist:_default_revctrl"] + ["svn_cvs = setuptools.command.sdist:_default_revctrl"], + + + "setuptools.installation": + ['eggsecutable = setuptools.command.easy_install:bootstrap'], }, classifiers = [f.strip() for f in """ @@ -117,7 +121,3 @@ setup( - - - - |