summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorphillip.eby <phillip.eby@6015fed2-1504-0410-9fe1-9d1591cc4771>2006-12-29 00:06:23 +0000
committerphillip.eby <phillip.eby@6015fed2-1504-0410-9fe1-9d1591cc4771>2006-12-29 00:06:23 +0000
commit29218c60b02b98d8f366108bee90efc6d51bf37a (patch)
treea16706c394aaf7d36f8738f830aadc7cdb669958 /setup.py
parent51a0d33e14476efd70a2c0d04fb7d2ea88f84b95 (diff)
downloadpython-setuptools-29218c60b02b98d8f366108bee90efc6d51bf37a.tar.gz
New installation instructions and credits
git-svn-id: http://svn.python.org/projects/sandbox/trunk/setuptools@53175 6015fed2-1504-0410-9fe1-9d1591cc4771
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py34
1 files changed, 17 insertions, 17 deletions
diff --git a/setup.py b/setup.py
index c936d04..22ce944 100755
--- a/setup.py
+++ b/setup.py
@@ -1,38 +1,31 @@
#!/usr/bin/env python
"""Distutils setup file, used to install or test 'setuptools'"""
-def get_description():
- # Get our long description from the documentation
- f = file('setuptools.txt')
- lines = []
- for line in f:
- if not line.strip():
- break # skip to first blank line
- for line in f:
- if line.startswith('.. contents::'):
- break # read to table of contents
- lines.append(line)
- f.close()
- return ''.join(lines)
-
from distutils.util import convert_path
-d = {}; execfile(convert_path('setuptools/command/__init__.py'), d)
+
+d = {}
+execfile(convert_path('setuptools/command/__init__.py'), d)
+
SETUP_COMMANDS = d['__all__']
VERSION = "0.7a1"
+
from setuptools import setup, find_packages
import sys
+
modules = ['pkg_resources','easy_install']
+
if sys.version<"2.5":
modules += ['_pkgutil', 'doctest', 'pydoc'] # fixups for older Pythons
+
setup(
name="setuptools",
version=VERSION,
description="Download, build, install, upgrade, and uninstall Python "
"packages -- easily!",
author="Phillip J. Eby",
- author_email="peak@eby-sarna.com",
+ author_email="distutils-sig@python.org",
license="PSF or ZPL",
- long_description = get_description(),
+ long_description = open('README.txt').read(),
keywords = "CPAN PyPI distutils eggs package management",
url = "http://peak.telecommunity.com/DevCenter/setuptools",
test_suite = 'setuptools.tests',
@@ -84,6 +77,9 @@ setup(
['eggsecutable = setuptools.command.easy_install:bootstrap'],
},
+
+
+
classifiers = [f.strip() for f in """
Development Status :: 3 - Alpha
Intended Audience :: Developers
@@ -121,3 +117,7 @@ setup(
+
+
+
+