diff options
author | phillip.eby <phillip.eby@6015fed2-1504-0410-9fe1-9d1591cc4771> | 2009-10-12 19:58:46 +0000 |
---|---|---|
committer | phillip.eby <phillip.eby@6015fed2-1504-0410-9fe1-9d1591cc4771> | 2009-10-12 19:58:46 +0000 |
commit | 34c3affcf42ad5371ee8349a303792957debd0f3 (patch) | |
tree | 399f9651078bb5dda7a73a7a2a4600a83599a4bd /setup.py | |
parent | 5453f0a279b620a1c972a469e115aedc288fa8da (diff) | |
download | python-setuptools-34c3affcf42ad5371ee8349a303792957debd0f3.tar.gz |
Major updates and fixes include:
* Fix for the Python 2.6.3 build_ext API change
* Support for the most recent Sourceforge download link insanity
* Support for SVN 1.6
* Stop crashing on certain types of HTTP error
* Stop re-trying URLs that already failed retrieval once
* Fixes for various dependency management problems such as looping
builds, re-downloading packages already present on sys.path (but not
in a registered "site" directory), and randomly preferring local -f
packages over local installed packages
* Prevent lots of spurious "already imported from another path" warnings
(e.g. when pkg_resources is imported late)
* Ensure C libraries (as opposed to extensions) are also built when
doing bdist_egg
* Fixed running the "test" command under Python 2.6+
Other changes:
* Misc. documentation fixes
* Improved Jython support
* Fewer warnings under Python 2.6+
* Warn when 'packages' uses paths instead of package names (because it
causes other problems, like spurious "already imported" warnings)
* Stop using /usr/bin/sw_vers on Mac OS (replaced w/'platform' module
calls)
Note: This is NOT a merge from Distribute; upon review, many of the
tracker-submitted patches used as a basis for forking were incorrect,
incomplete, introduced new bugs, or were not addressing the root
causes. (E.g., one of the changes in this patch fixes three superficially
unrelated issues in the setuptools bug tracker.) Careful review will be
required if you want to merge this work back into Distribute.
git-svn-id: http://svn.python.org/projects/sandbox/trunk/setuptools@75384 6015fed2-1504-0410-9fe1-9d1591cc4771
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 3 |
1 files changed, 1 insertions, 2 deletions
@@ -54,6 +54,7 @@ setup( "dependency_links = setuptools.dist:assert_string_list", "test_loader = setuptools.dist:check_importable", "test_runner = setuptools.dist:check_importable", + "packages = setuptools.dist:check_packages", ], "egg_info.writers": [ "PKG-INFO = setuptools.command.egg_info:write_pkg_info", @@ -79,8 +80,6 @@ setup( }, - - classifiers = [f.strip() for f in """ Development Status :: 3 - Alpha Intended Audience :: Developers |