summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorpje <pje@6015fed2-1504-0410-9fe1-9d1591cc4771>2005-09-17 01:13:02 +0000
committerpje <pje@6015fed2-1504-0410-9fe1-9d1591cc4771>2005-09-17 01:13:02 +0000
commit3a37fbb2094cfe88013e5bd4a088bfa06a63e9dc (patch)
treeb9aa9ca6d2049ccb783d15d7aa1d72826655e399 /setup.py
parent5e987538b89e921f45a838c9683ed350a9a78333 (diff)
downloadpython-setuptools-3a37fbb2094cfe88013e5bd4a088bfa06a63e9dc.tar.gz
Added support to solve the infamous "we want .py on Windows, no
extension elsewhere" problem, while also bypassing the need for PATHEXT on Windows, and in fact the need to even write script files at all, for any platform. Instead, you define "entry points" in your setup script, in this case the names of the scripts you want (without extensions) and the functions that should be imported and run to implement the scripts. Setuptools will then generate platform-appropriate script files at install time, including an .exe wrapper when installing on Windows. git-svn-id: http://svn.python.org/projects/sandbox/trunk/setuptools@41246 6015fed2-1504-0410-9fe1-9d1591cc4771
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py51
1 files changed, 46 insertions, 5 deletions
diff --git a/setup.py b/setup.py
index cea8d91..10d1979 100755
--- a/setup.py
+++ b/setup.py
@@ -34,12 +34,12 @@ setup(
keywords = "CPAN PyPI distutils eggs package management",
url = "http://peak.telecommunity.com/DevCenter/setuptools",
test_suite = 'setuptools.tests.test_suite',
-
packages = find_packages(),
+ package_data = {'setuptools': ['launcher.exe']},
py_modules = ['pkg_resources', 'easy_install'],
- scripts = ['easy_install.py'],
+
- zip_safe = False, # We want 'python -m easy_install' to work :(
+ zip_safe = False, # We want 'python -m easy_install' to work, for now :(
entry_points = {
"distutils.commands" : [
"%(cmd)s = setuptools.command.%(cmd)s:%(cmd)s" % locals()
@@ -63,9 +63,9 @@ setup(
"top_level.txt = setuptools.command.egg_info:write_toplevel_names",
"depends.txt = setuptools.command.egg_info:warn_depends_obsolete",
],
+ "console_scripts":
+ ["easy_install = setuptools.command.easy_install:main"],
},
- # uncomment for testing
- # setup_requires = ['setuptools>=0.6a0'],
classifiers = [f.strip() for f in """
Development Status :: 3 - Alpha
@@ -78,5 +78,46 @@ setup(
Topic :: System :: Archiving :: Packaging
Topic :: System :: Systems Administration
Topic :: Utilities""".splitlines() if f.strip()]
+
+
+ # uncomment for testing
+ # setup_requires = ['setuptools>=0.6a0'],
)
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+
+