summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorpje <pje@6015fed2-1504-0410-9fe1-9d1591cc4771>2005-09-24 17:28:56 +0000
committerpje <pje@6015fed2-1504-0410-9fe1-9d1591cc4771>2005-09-24 17:28:56 +0000
commit3dee91619b79fd5932bdc192f3d9a583e263e6b7 (patch)
tree68c6deed0bbe538ae34fd703dfd7902ab9cdd5ae /setup.py
parent10ff83770638089f0df268e97d5156147369c128 (diff)
downloadpython-setuptools-3dee91619b79fd5932bdc192f3d9a583e263e6b7.tar.gz
Improve backward compatibility, so that users running easy_install.py or
python -m easy_install get a clearer error message. git-svn-id: http://svn.python.org/projects/sandbox/trunk/setuptools@41249 6015fed2-1504-0410-9fe1-9d1591cc4771
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py12
1 files changed, 6 insertions, 6 deletions
diff --git a/setup.py b/setup.py
index b9046d8..cf9373e 100755
--- a/setup.py
+++ b/setup.py
@@ -14,13 +14,14 @@ def get_description():
lines.append(line)
f.close()
return ''.join(lines)
-
-VERSION = "0.6a2"
+VERSION = "0.6a2"
from setuptools import setup, find_packages
import sys
-
from setuptools.command import __all__ as SETUP_COMMANDS
+scripts = []
+if sys.platform != "win32":
+ scripts = ["easy_install.py"] # for backward compatibility only
setup(
name="setuptools",
@@ -38,7 +39,6 @@ setup(
package_data = {'setuptools': ['launcher.exe']},
py_modules = ['pkg_resources', 'easy_install'],
-
zip_safe = False, # We want 'python -m easy_install' to work, for now :(
entry_points = {
"distutils.commands" : [
@@ -77,8 +77,8 @@ setup(
Topic :: Software Development :: Libraries :: Python Modules
Topic :: System :: Archiving :: Packaging
Topic :: System :: Systems Administration
- Topic :: Utilities""".splitlines() if f.strip()]
-
+ Topic :: Utilities""".splitlines() if f.strip()],
+ scripts = scripts,
# uncomment for testing
# setup_requires = ['setuptools>=0.6a0'],