summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorphillip.eby <phillip.eby@6015fed2-1504-0410-9fe1-9d1591cc4771>2005-11-18 04:37:31 +0000
committerphillip.eby <phillip.eby@6015fed2-1504-0410-9fe1-9d1591cc4771>2005-11-18 04:37:31 +0000
commit9b9667e8064dca12f640b7124a9dddbdbdad4096 (patch)
treefa4e932d263aa02a1c9d80cc2cb80f33d5ce6f47 /setup.py
parent2cacfc82b25e69ee4716baba0df694b4b631a352 (diff)
downloadpython-setuptools-9b9667e8064dca12f640b7124a9dddbdbdad4096.tar.gz
Added the ``include_package_data`` keyword to ``setup()``, allowing you to
automatically include any package data listed in revision control or ``MANIFEST.in``. Now projects can manage their data files and source manifests without having to maintain two ways to express the same file list. Yay! git-svn-id: http://svn.python.org/projects/sandbox/trunk/setuptools@41473 6015fed2-1504-0410-9fe1-9d1591cc4771
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py4
1 files changed, 2 insertions, 2 deletions
diff --git a/setup.py b/setup.py
index deeb1d8..cfe59f9 100755
--- a/setup.py
+++ b/setup.py
@@ -36,7 +36,7 @@ setup(
url = "http://peak.telecommunity.com/DevCenter/setuptools",
test_suite = 'setuptools.tests.test_suite',
packages = find_packages(),
- package_data = {'setuptools': ['*.exe']},
+ include_package_data = True,
py_modules = ['pkg_resources', 'easy_install', 'site'],
zip_safe = False, # We want 'python -m easy_install' to work, for now :(
@@ -53,6 +53,7 @@ setup(
"entry_points = setuptools.dist:check_entry_points",
"test_suite = setuptools.dist:check_test_suite",
"zip_safe = setuptools.dist:assert_bool",
+ "include_package_data = setuptools.dist:assert_bool",
],
"egg_info.writers": [
"PKG-INFO = setuptools.command.egg_info:write_pkg_info",
@@ -66,7 +67,6 @@ setup(
"console_scripts":
["easy_install = setuptools.command.easy_install:main"],
},
-
classifiers = [f.strip() for f in """
Development Status :: 3 - Alpha
Intended Audience :: Developers