summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorpje <pje@6015fed2-1504-0410-9fe1-9d1591cc4771>2005-10-17 02:26:39 +0000
committerpje <pje@6015fed2-1504-0410-9fe1-9d1591cc4771>2005-10-17 02:26:39 +0000
commitc70724954e8f3d74adbf14dfae5d294cfd3a712c (patch)
treee931e6f30fe51eb6ee968a008e9ac4c439249ea8 /setup.py
parent64091da29d13967a2bce9f44b30e5beda0bc1ab8 (diff)
downloadpython-setuptools-c70724954e8f3d74adbf14dfae5d294cfd3a712c.tar.gz
Significantly enhanced support and docs for "non-root" installation,
including both "virtual" and PYTHONPATH-based installs. The activation precedence of distributions has also changed so that PYTHONPATH-based non-root installs can include eggs that override system-defined packages (whether managed or unmanaged). This version should eliminate most common installation complaints from non-root Python users. Note: this version includes a hacked 'site.py' to support processing .pth files in directories that come *before* site-packages on sys.path. However, because of its placement, it should only come into play when a user puts the setuptools .egg file *directly* on PYTHONPATH, so it doesn't affect "virtual" or "root" installations. It's strictly to provide support for luddites who refuse to give up their existing non-root PYTHONPATH setup unless you pry it from their cold, dead hands. :) git-svn-id: http://svn.python.org/projects/sandbox/trunk/setuptools@41262 6015fed2-1504-0410-9fe1-9d1591cc4771
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index eb826fa..4a2d4c7 100755
--- a/setup.py
+++ b/setup.py
@@ -37,7 +37,7 @@ setup(
test_suite = 'setuptools.tests.test_suite',
packages = find_packages(),
package_data = {'setuptools': ['*.exe']},
- py_modules = ['pkg_resources', 'easy_install'],
+ py_modules = ['pkg_resources', 'easy_install', 'site'],
zip_safe = False, # We want 'python -m easy_install' to work, for now :(
entry_points = {