summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorStefan Behnel <stefan_ml@behnel.de>2014-02-16 12:20:50 +0100
committerStefan Behnel <stefan_ml@behnel.de>2014-02-16 12:20:50 +0100
commit372e712e389b16667e4a85f22f378fd454a08690 (patch)
treef13955b0726339721782b9f86e4e1efa51634bf1 /setup.py
parent291a8e9b151c64e6152f652aaf4d3b741e5326a5 (diff)
downloadpython-lxml-372e712e389b16667e4a85f22f378fd454a08690.tar.gz
add more optional deps
Diffstat (limited to 'setup.py')
-rw-r--r--setup.py2
1 files changed, 2 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index bc649e83..308dbb75 100644
--- a/setup.py
+++ b/setup.py
@@ -62,6 +62,8 @@ if 'setuptools' in sys.modules:
extra_options['extras_require'] = {
'source': deps,
'cssselect': 'cssselect>=0.7',
+ 'html5': 'html5lib',
+ 'htmlsoup': 'BeautifulSoup4',
}
extra_options.update(setupinfo.extra_setup_args())