summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorEric Lin <anselor@gmail.com>2021-01-11 14:06:16 -0500
committerEric Lin <anselor@gmail.com>2021-01-22 10:44:09 -0500
commitce907373694c0203e4d8a4a469c9194e5e4fb970 (patch)
tree59b89f886a42547cb909a26984231e88e8959df1
parenta3b1b6ddf81cdc0b253f15feeb167ff348afd14f (diff)
downloadcmd2-git-pep561.tar.gz
Added py.typed to signal that we support type annotations for PEP-561. Fixes #1036pep561
-rw-r--r--cmd2/py.typed1
-rw-r--r--plugins/ext_test/cmd2_ext_test/py.typed1
-rw-r--r--plugins/ext_test/setup.py5
-rwxr-xr-xsetup.py5
4 files changed, 12 insertions, 0 deletions
diff --git a/cmd2/py.typed b/cmd2/py.typed
new file mode 100644
index 00000000..17af580f
--- /dev/null
+++ b/cmd2/py.typed
@@ -0,0 +1 @@
+# PEP 561
diff --git a/plugins/ext_test/cmd2_ext_test/py.typed b/plugins/ext_test/cmd2_ext_test/py.typed
new file mode 100644
index 00000000..17af580f
--- /dev/null
+++ b/plugins/ext_test/cmd2_ext_test/py.typed
@@ -0,0 +1 @@
+# PEP 561
diff --git a/plugins/ext_test/setup.py b/plugins/ext_test/setup.py
index 70b264b5..c78a8612 100644
--- a/plugins/ext_test/setup.py
+++ b/plugins/ext_test/setup.py
@@ -16,6 +16,10 @@ scm_version = {
'git_describe_command': 'git describe --dirty --tags --long --match "plugin-ext-test*"',
}
+PACKAGE_DATA = {
+ 'cmd2_ext_test': ['py.typed'],
+}
+
setuptools.setup(
name='cmd2-ext-test',
version=scm_version,
@@ -30,6 +34,7 @@ setuptools.setup(
url='https://github.com/python-cmd2/cmd2/tree/master/plugins/ext_test',
license='MIT',
+ package_data=PACKAGE_DATA,
packages=['cmd2_ext_test'],
python_requires='>=3.5',
diff --git a/setup.py b/setup.py
index 46a2ad05..5e2995a9 100755
--- a/setup.py
+++ b/setup.py
@@ -70,6 +70,10 @@ EXTRAS_REQUIRE = {
]
}
+PACKAGE_DATA = {
+ 'cmd2': ['py.typed'],
+}
+
setup(
name="cmd2",
use_scm_version={
@@ -84,6 +88,7 @@ setup(
url='https://github.com/python-cmd2/cmd2',
license='MIT',
platforms=['any'],
+ package_data=PACKAGE_DATA,
packages=['cmd2'],
keywords='command prompt console cmd',
python_requires='>=3.5',