summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 46a2ad05..5e2995a9 100755
--- a/setup.py
+++ b/setup.py
@@ -70,6 +70,10 @@ EXTRAS_REQUIRE = {
]
}
+PACKAGE_DATA = {
+ 'cmd2': ['py.typed'],
+}
+
setup(
name="cmd2",
use_scm_version={
@@ -84,6 +88,7 @@ setup(
url='https://github.com/python-cmd2/cmd2',
license='MIT',
platforms=['any'],
+ package_data=PACKAGE_DATA,
packages=['cmd2'],
keywords='command prompt console cmd',
python_requires='>=3.5',