summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorEric Lin <anselor@gmail.com>2021-01-11 14:06:16 -0500
committerEric Lin <anselor@gmail.com>2021-01-22 10:44:09 -0500
commitce907373694c0203e4d8a4a469c9194e5e4fb970 (patch)
tree59b89f886a42547cb909a26984231e88e8959df1 /setup.py
parenta3b1b6ddf81cdc0b253f15feeb167ff348afd14f (diff)
downloadcmd2-git-pep561.tar.gz
Added py.typed to signal that we support type annotations for PEP-561. Fixes #1036pep561
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py5
1 files changed, 5 insertions, 0 deletions
diff --git a/setup.py b/setup.py
index 46a2ad05..5e2995a9 100755
--- a/setup.py
+++ b/setup.py
@@ -70,6 +70,10 @@ EXTRAS_REQUIRE = {
]
}
+PACKAGE_DATA = {
+ 'cmd2': ['py.typed'],
+}
+
setup(
name="cmd2",
use_scm_version={
@@ -84,6 +88,7 @@ setup(
url='https://github.com/python-cmd2/cmd2',
license='MIT',
platforms=['any'],
+ package_data=PACKAGE_DATA,
packages=['cmd2'],
keywords='command prompt console cmd',
python_requires='>=3.5',