summaryrefslogtreecommitdiff
path: root/setup.py
diff options
context:
space:
mode:
authorSebastian Thiel <sebastian.thiel@icloud.com>2022-10-11 07:45:32 +0800
committerSebastian Thiel <sebastian.thiel@icloud.com>2022-10-11 07:45:32 +0800
commitbe3400b79ec15b84cd13a3ba30da289cdd98b878 (patch)
tree2b2e4560847932f655a6042152d3d28e0d052ed2 /setup.py
parentdc140c0f794e35dd3106453cc5443feb5ab2a9e3 (diff)
downloadgitpython-be3400b79ec15b84cd13a3ba30da289cdd98b878.tar.gz
fix version replacement in `setup.py` (#1500)
It would fail to perform the replacement, but unfortunately wouldn't stop the release process. The latter could be done, but isn't implemented either as it's hard to test given everything is runtime.
Diffstat (limited to 'setup.py')
-rwxr-xr-xsetup.py2
1 files changed, 1 insertions, 1 deletions
diff --git a/setup.py b/setup.py
index 5494cf48..daad454d 100755
--- a/setup.py
+++ b/setup.py
@@ -47,7 +47,7 @@ def _stamp_version(filename: str) -> None:
with open(filename, "r") as f:
for line in f:
if "__version__ =" in line:
- line = line.replace("'git'", "'%s'" % VERSION)
+ line = line.replace("\"git\"", "'%s'" % VERSION)
found = True
out.append(line)
except OSError: