diff options
author | Sebastian Thiel <sebastian.thiel@icloud.com> | 2022-10-11 07:45:32 +0800 |
---|---|---|
committer | Sebastian Thiel <sebastian.thiel@icloud.com> | 2022-10-11 07:45:32 +0800 |
commit | be3400b79ec15b84cd13a3ba30da289cdd98b878 (patch) | |
tree | 2b2e4560847932f655a6042152d3d28e0d052ed2 /setup.py | |
parent | dc140c0f794e35dd3106453cc5443feb5ab2a9e3 (diff) | |
download | gitpython-be3400b79ec15b84cd13a3ba30da289cdd98b878.tar.gz |
fix version replacement in `setup.py` (#1500)
It would fail to perform the replacement, but unfortunately wouldn't
stop the release process.
The latter could be done, but isn't implemented either as it's hard
to test given everything is runtime.
Diffstat (limited to 'setup.py')
-rwxr-xr-x | setup.py | 2 |
1 files changed, 1 insertions, 1 deletions
@@ -47,7 +47,7 @@ def _stamp_version(filename: str) -> None: with open(filename, "r") as f: for line in f: if "__version__ =" in line: - line = line.replace("'git'", "'%s'" % VERSION) + line = line.replace("\"git\"", "'%s'" % VERSION) found = True out.append(line) except OSError: |